Teraz jest 08 maja 2021 23:39:05




Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 22 ]  Przejdź na stronę 1, 2  Następna strona
PW2 blokada "Important: Security Update for Kindle" 
Autor Wiadomość
Użytkownik

Dołączył(a): 05 gru 2014 2:08:52
Posty: 27
eCzytnik: Jeszcze żaden
Post PW2 blokada "Important: Security Update for Kindle"
Witam,
Na moim PW2 mam zainstalowanego jailbreak'a i spolszczenie na sofce 5.4.3.2. Mam też mod zabezpieczający przed automatyczną aktualizacją.

Niestety jakiś czas temu na ekranie pojawiła się nowa książka: "07-2016 Important: Security Update for Kindle"
Jeżeli dobrze rozumiem to po włączeniu WiFi mój Kindle automatycznie zaktualizuje się do najnowszej wersji?

Czy da się to w jakiś sposób zablokować?


06 wrz 2016 14:28:19
Zobacz profil
Użytkownik
Avatar użytkownika

Dołączył(a): 21 lip 2011 9:46:47
Posty: 264
eCzytnik: KoboT,NST,NGP,K3G, KPW2,KPW3,TolV2
Post Re: PW2 blokada "Important: Security Update for Kindle"
athame napisał(a):
chmura ADIOS

Naprawdę? To przykre. Ja również używam PW2 w wersji spolszczonej przez danana72 z różnymi dodatkami. Cenna jest dla mnie jednak synchronizacja ostatnio czytanej strony pomiędzy różnymi urządzeniami, więc będę miała problem decyzyjny – polski interfejs lub synchronizacja.

Człowiek czuje się wyróżniony, gdy urządzenie komunikuje się z nim w ojczystym języku. Informacje po angielsku jedynie przyjmuję do wiadomości, a te po polsku czytam z uśmiechem. Nawet jeśli jest to informacja, która właśnie mnie powitała po otworzeniu okładki czytnika:

Obrazek


06 wrz 2016 17:13:54
Zobacz profil
Użytkownik

Dołączył(a): 05 gru 2014 2:08:52
Posty: 27
eCzytnik: Jeszcze żaden
Post Re: PW2 blokada "Important: Security Update for Kindle"
Nie wiedziałem, że przy braku aktywności traci się dostęp do chmury.

Z czytnika korzysta głównie żona i jest zadowolona z polonizacji i rozszezrzeń danana72.
Jeżeli rzeczywiście istnieje ryzyko zablokowania dostępu do chmury to cóż... będę zmuszony zaktualizować.

Czy jest jakaś prosta metoda na pozbycie się śmieci z jailbreak'a i spolszczenia przed przeprowadzeniem aktualizacji?


07 wrz 2016 13:23:23
Zobacz profil
Użytkownik
Avatar użytkownika

Dołączył(a): 21 lip 2011 9:46:47
Posty: 264
eCzytnik: KoboT,NST,NGP,K3G, KPW2,KPW3,TolV2
Post Re: PW2 blokada "Important: Security Update for Kindle"
meriox napisał(a):
Czy jest jakaś prosta metoda na pozbycie się śmieci z jailbreak'a i spolszczenia przed przeprowadzeniem aktualizacji?

O ile dobrze myślę trzeba odinstalowywać w takiej kolejności:
* dodatki (np. pw2 narrow margin patch, fonthack)
* sama lokalizacja
* dodatki do JB (np. MRPI)
* sam JB

Będę wdzięczna o weryfikację, bo mnie również może czekać taka operacja. Być może można to uprościć.

Osobiście poczekam i usunę lokalizację wraz z JB tylko jeśli chmura przestanie działać.
Potem chciałabym:
* zainstalować firmware w wersji 5.6.5
* zainstalować JB + odpowiednie dodatki (szczególnie ważne są dla mnie węższe marginesy)
* zaktualizować do najnowszej wersji firmware


07 wrz 2016 16:05:16
Zobacz profil
Użytkownik

Dołączył(a): 04 lis 2011 11:10:45
Posty: 151
eCzytnik: Kindle 3, Paperwhite 2
Post Re: PW2 blokada "Important: Security Update for Kindle"
Aktualizacja związana z wygaśnięciem ważności certyfikatów po 22 marca 2016r. (co miało skutkować brakiem dostępu do chmury) dotyczyła starszych modeli (od Kindle 1 do PW1). Dla PW2 aktualizacja ta nie była wymagana. Nie wiem nic o tym, żeby coś się w tej kwestii zmieniło.
Na czytnikach PW2 z oprogramowaniem 5.4.3.2 blokada aktualizacji BackDoorLock (wbudowana z spolszczenie) była jeszcze skuteczna i nie sądzę, żeby należało się obawiać, że czytnik sam się zaktualizuje.
Jeśli chcecie samodzielnie wykonać aktualizację fw, to tak jak podała Becky konieczne będzie odinstalowanie nakładki na spolszczenie (jeśli była wykorzystywana) i samego spolszczenia. Wskazane byłoby również odinstalowanie innych wgranych hacków. Natomiast JB nie ma potrzeby odinstalowywać, przeciwnie warto go zaktualizować do wersji 1.14.N i zainstalować bridge (znajduje się w tej samej paczce), bo to zapewni, że JB przetrwa kolejne aktualizacje oprogramowania.
Ja jednak na razie (dopóki funkcje sieciowe działają) nie wykonywałbym nerwowych ruchów.

_________________
“A reader lives a thousand lives before he dies. The man who never reads lives only one.”
A Dance With Dragons.


07 wrz 2016 22:45:32
Zobacz profil
Użytkownik

Dołączył(a): 05 gru 2014 2:08:52
Posty: 27
eCzytnik: Jeszcze żaden
Post Re: PW2 blokada "Important: Security Update for Kindle"
danan72, u mnie komunikat o aktualizacji pojawił się mimo blokady. Co więcej... w drugim punkcie mam następujące info:

2. Connect to Wi-Fi. The update should download and begin automatically, even if your e-reader is asleep.

Stąd moje obawy przed włączeniem Wi-Fi.
Czy powstała jakaś inna blokada którą mógłbym dorzucić do mojego PW2?


07 wrz 2016 23:05:29
Zobacz profil
Użytkownik
Avatar użytkownika

Dołączył(a): 21 lip 2011 9:46:47
Posty: 264
eCzytnik: KoboT,NST,NGP,K3G, KPW2,KPW3,TolV2
Post Re: PW2 blokada "Important: Security Update for Kindle"
U mnie też pojawił się komunikat, ale – ponieważ mam założone blokady – uznałam, że jest to informacja dla tych, którzy po prostu z jakiegoś powodu nie aktualizowali od dawna czytnika, więc Amazon wysłał im przypomnienie. Ta informacja to w końcu zwykły plik a nie firmware. Włączam wifi na chwilę codziennie aby zsynchronizować ostatnio czytaną stronę lub pobrać kolejne książki do czytania.

Dzięki, danan72 za uspokojenie. Na razie cieszę się z polskiego PW2 i po prostu czytam :)


07 wrz 2016 23:41:06
Zobacz profil
Użytkownik

Dołączył(a): 05 gru 2014 2:08:52
Posty: 27
eCzytnik: Jeszcze żaden
Post Re: PW2 blokada "Important: Security Update for Kindle"
Becky, może i masz rację ale punkt 2-gi może przestraszyć. Aktualizacja ma przebiec automatycznie po włączeniu Wi-Fi.


08 wrz 2016 7:16:59
Zobacz profil
Użytkownik

Dołączył(a): 22 sie 2016 23:06:59
Posty: 8
Post Re: PW2 blokada "Important: Security Update for Kindle"
athame napisał(a):
Pewną zachętą do pracy jest fakt, że JB znowu jest dostępny dla każdego, a FW jest bliźniacze w PW 2, PW 3, Kindle 7/8, Voyage i Oasis, więc te same tłumaczenia można zastosować do wszystkich tych modeli.


Czy to oznacza, że spolszczenie, które obecnie działa na PW 2 na FW 5.4.3.2 również będzie działać na Kindle 7 z tym FW czy jednak źle to rozumiem, bo chętnie wgrałbym spolszczenie właśnie do mojego Kindle 7? Dziękuję z góry za odpowiedź :)


23 wrz 2016 22:42:02
Zobacz profil
Użytkownik
Avatar użytkownika

Dołączył(a): 21 lip 2011 9:46:47
Posty: 264
eCzytnik: KoboT,NST,NGP,K3G, KPW2,KPW3,TolV2
Post Re: PW2 blokada "Important: Security Update for Kindle"
athame napisał(a):
Becky napisał(a):
* zainstalować firmware w wersji 5.6.5

Dlaczego akurat ta wersja, a nie najnowsza?

W swoim PW3 mam wersję 5.6.5, do którego jest działający JB i do którego mogłam wgrać mod zwężający marginesy.
Zostawiłam wersję 5.6.5, nie przechodząc na nowsze firmware (m.in. Bookerly, brak kropek, potem powrót kropek) – bo czytając, że JB przetrwa lub nie przetrwa nie decydowałam się na eksperymenty.

Dzisiaj zapewne zastosowałabym metodę opisaną tutaj.

Co do tłumaczenia – od razu po opublikowaniu pobrałam całość i pobieżnie zerknęłam, ale muszę znaleźć wolną chwilę, aby ogarnąć to dokładniej.
Być może jakimś sposobem byłoby posiadanie na czytniku aktualnej wersji (czyli tej z niepełnym tłumaczeniem) i przy normalnym użytkowaniu wyszukiwanie nieprzetłumaczonych elementów. Po zgromadzeniu pewnego pakietu (robiąc sobie zrzuty lub zdjęcia) przetłumaczenie w odpowiednich plikach i odesłanie. Są elementy pojawiające się tak rzadko (np. związane z wypożyczaniem książek, z którego nie korzystamy w Polsce), że chyba nie warto tracić czasu na ich tłumaczenie.


24 wrz 2016 10:10:57
Zobacz profil
Użytkownik

Dołączył(a): 22 sie 2016 23:06:59
Posty: 8
Post Re: PW2 blokada "Important: Security Update for Kindle"
athame napisał(a):
Obecną wersje można wgrać, z tym że wszystko co pojawiło się w wersjach 5.7.X i nowszych jest nieprzetłumaczone. Przy codziennym użytku angielskie zwroty pojawiają się uśredniając raz na ~1000 słów, więc trochę pozycji (niewiele) w różnych menu.


Czy w takim razie po zrobieniu Jailbreaka trzeba wgrać spolszczenie dla kindle Paperwhite 2 w wersji 5.4.3.2 czy mowa o jakimś innym pliku i czy jest on tutaj podany na forum? Jeśli tak to czy mógłbym prosić o link? Ponieważ przy wgraniu tego psolszczenia z PW2 wyskakuje komunikat "An invalid update file has been loaded on your device."


24 wrz 2016 15:08:40
Zobacz profil
Użytkownik

Dołączył(a): 22 sie 2016 23:06:59
Posty: 8
Post Re: PW2 blokada "Important: Security Update for Kindle"
Rozumiem. A czy w takim razie jest taka możliwość aby ktoś, a dokładnie Pan danan72 przygotował takie paczki? ;)


24 wrz 2016 16:58:04
Zobacz profil
Użytkownik

Dołączył(a): 04 lis 2011 11:10:45
Posty: 151
eCzytnik: Kindle 3, Paperwhite 2
Post Re: PW2 blokada "Important: Security Update for Kindle"
Gdyby tutaj chodziło o samo przygotowanie paczki instalacyjnej, to zrobiłbym to już dawno. Jednak najpierw trzeba przygotować wsad, który znajdzie się w tej paczce a to nie jest takie proste ;)
Robota przy tym jest żmudna a dodatkowo występują okoliczności zniechęcające:
-duża częstotliwość wydawania nowych wersji, które mogą powodować, że pracę trzeba zacząć od początku (no, prawie od początku :) ),
-brak możliwości kompletnej polonizacji, bo część fraz znajduje się w rozszerzeniach acx i nie da się do nich dobrać.
W związku z powyższym pozostawiłem na swoim PW2 całkowicie spolonizowany soft 5.4.3.2 a na Voyage używam softu nieprzetłumaczonego.
Ale oczywiście kibicuję poczynaniom athame i jeśli mogę, to staram się pomagać.

_________________
“A reader lives a thousand lives before he dies. The man who never reads lives only one.”
A Dance With Dragons.


06 paź 2016 16:10:10
Zobacz profil
Użytkownik

Dołączył(a): 04 lis 2011 11:10:45
Posty: 151
eCzytnik: Kindle 3, Paperwhite 2
Post Re: PW2 blokada "Important: Security Update for Kindle"
athame napisał(a):
Od kiedy to ACX nie można polonizować?

Edycja fraz w plikach ACX nie jest oczywiście problemem. Tyle, że po modyfikacji muszą być one odpowiednio podpisane, bo inaczej nie będą działać na czytniku (spolonizowane opcje nie będą widoczne w menu). Sposób na podpisanie plików ACX znalazł kiedyś @dsmid z forum MR ale jego metoda jest już nieaktualna.

_________________
“A reader lives a thousand lives before he dies. The man who never reads lives only one.”
A Dance With Dragons.


06 paź 2016 21:45:37
Zobacz profil
Wyświetl posty nie starsze niż:  Sortuj wg  
Utwórz nowy wątek Odpowiedz w wątku  [ Posty: 22 ]  Przejdź na stronę 1, 2  Następna strona


Kto przegląda forum

Użytkownicy przeglądający to forum: Brak zalogowanych użytkowników i 1 gość


Nie możesz rozpoczynać nowych wątków
Nie możesz odpowiadać w wątkach
Nie możesz edytować swoich postów
Nie możesz usuwać swoich postów

Skocz do:  
cron